JustAnswer Blog: Tech Support

You are here

Are Updates OK for Old Phones?

Old Phone

Photo Credit: Flickr/Scott Schiller

Are Updates OK for Old Phones?

By Carolyn Hauck on October 06, 2015

A few weeks ago Apple rolled out its iOS 9 update for iPhones no older than 4s, tablets no older than the 2 and 5th generation iPod touch. And yesterday, Android began its roll out of 6.0 Marshmallow for Nexus Platforms 5, 6, 7, 9 and Player.

So our big question: If you have an older phone, is it a good idea to update? Viet, a Tech Expert on JustAnswer, was happy to give us his safe-bet answer:

“The latest upgrade version for iPhones, iOS 9, is very new and is currently known to slow down older iPhone models, so I do not recommend upgrading until all the bugs are resolved.

Android Marshmallow is even newer, so usually, for any device, I would wait a couple of weeks to a month for reviews before updating this one as well.”

Although it’s exciting to see the new features on your device, if the update is going to slow your device down it’s probably not worth it. Especially, if the changes aren’t really all that noticeable. For example, iOS 8, the update version for iPhones before the current one, notoriously slowed down phones and made consumers frustrated. Apple has been saying that this won’t be a problem with iOS 9. However, as Viet pointed out, there have been reports of lag times and difficult downloads. As well, 4s phones will miss out on some key and fun features, plus speed improvements that newer iPhones will enjoy, like Apple Pay, Siri Suggestions or Drawing with Notes. On the plus side, Apple will continue to support 4s with bug fixes, so if you do go ahead and update, you’ll get the bug fixes that come along on all the features your phone supports.

The consensus across the board for 4s phone owners is to stick with iOS 7 or update bug fixes in iOS 8. iOS 9 isn’t worth it. As for Android? Well, it will be a few weeks before we know for sure.

Send a quick note to a Tech Expert and get his or her take on whether or not you should update.